Jump to content

Проблема с ШДК LC-1 и ее решение


Recommended Posts

В один прекрасный день мой ШДК LC-1 забарахлил. Прога лог-воркс показывает нормальную смесь а по логу матрицы примерно в три раза богаче... например 14.7 и 3.5 . переключаю на аналоговый вход J5OLT (пин-39) тоже самое.

 

Решение проблемы. Запускаем LM-программер и по новой программируем (см. хелп матрицы). особое внимание на установленную стехиометрию. после этой процедуры все приходит в норму.

Link to comment

То есть всё это происходило через COM порт?

 

процедура программирования только через ком-порт. никаких переходников. а неверные показания в логе матрицы были и при работе через USB-COM так и через аналоговый выход .

Link to comment

 

процедура программирования только через ком-порт. никаких переходников. а неверные показания в логе матрицы были и при работе через USB-COM так и через аналоговый выход .

Я пока такого не замечал.

Но не раз делал сброс калибровок с LM программера.

Он в этом режиме начанает прожигать элемент.

То есть нагреватель нагревается до высокой температуры так что керамический элемент начанает светиться. Так что если поднести зажигалку и пустить газ то он вспыхивает.

Через какое то время температура снижается до нормальной.

Как я понял происходит очистка элемента от сол и всего остального.

Edited by Phant0m
Link to comment

По поводу ЛМ-1. Я уже говорил Максу следующий глюк - незнаю будет ли он исправлен во второй матрице: если в процессе настройки матрицей происходит физический разрыв связи ЛМ-1 и матрицы то последняя видит тот состав смеси который был последним и начинает плясать обогащая или обедняя смесь. Пару раз так чуть не закосипорил практически уже отктаные калибровки.

Link to comment

По поводу ЛМ-1. Я уже говорил Максу следующий глюк - незнаю будет ли он исправлен во второй матрице: если в процессе настройки матрицей происходит физический разрыв связи ЛМ-1 и матрицы то последняя видит тот состав смеси который был последним и начинает плясать обогащая или обедняя смесь. Пару раз так чуть не закосипорил практически уже отктаные калибровки.

этот глюк исправлен в той версии что будет скоро

Link to comment
  • 4 weeks later...

Хотел спросить: кто как кабель от ШДК до салона тянет?

Я обычно через окно и поджимал стеклом. Но в последний раз налетели на кочку и разъем расколашматило. Присматриваюсь к отверстию рычага КПП.

Edited by techtech
Link to comment
Хотел спросить: кто как кабель от ШДК до салона тянет?

Я обычно через окно и поджимал стеклом. Но в последний раз налетели на кочку и разъем расколашматило. Присматриваюсь к отверстию рычага КПП.

 

Я через капот и дверь.

Привязываю контроллер стяжками к чему нить что под руку попало.

Кабель конечно же плющит дверью. Но скоро один фиг всё переделаю.

Только вот всё руки не доходят.

Link to comment

Может ли кто нибудь померять сопротивление нагревателя ЛЗ? У меня 3 Ом между белым и серым проводом. Но вот при нажатии 'reset" в LM programmer ничего у меня в ЛЗ до красна не греется и задолбала таки ошибка 8.

Link to comment
Может ли кто нибудь померять сопротивление нагревателя ЛЗ? У меня 3 Ом между белым и серым проводом. Но вот при нажатии 'reset" в LM programmer ничего у меня в ЛЗ до красна не греется и задолбала таки ошибка 8.

Ну так дядька ошибка 8 выскакивает по причине того что у тебя масса датчика не подключина.

Link to comment

Ну так дядька ошибка 8 выскакивает по причине того что у тебя масса датчика не подключина.

Да все верно :27: Там оказывается фишка такая если первое включение прошло без подключенной "белой" массы то потом даже с подключенным проводом массы система в рабочий режим не входит :6: Вот так я кстати оконцевал кабель ЛС-1

Link to comment

Да все верно :27: Там оказывается фишка такая если первое включение прошло без подключенной "белой" массы то потом даже с подключенным проводом массы система в рабочий режим не входит :6: Вот так я кстати оконцевал кабель ЛС-1

Ну само собой он без массы при сбросе калибровки работать опосля не будет.

Link to comment
  • 4 weeks later...

У меня в последнее время происходили неадекватные вещи с настройкой.

То глохла на светофорах то вечно перекалибровывалась. В общем сплошной геморрой.

В последние дни начались произвольные скачки показаний ШДК, колебания ЕДЕНИЦ.

Решил снять и откалибровать. Открутил датчик, а он в толстом слое сажи. Снял контроллер и понёс всё чистить. В последний раз калибровал месяца 2 назад. Снаружи почистил тряпочкой смоченной спиртом. Подумал что внутри творится тоже самое. Ну думаю рискну промою его в спирте. Залил в тару плюхнул туда чувствительную часть датчика, поболтал немного. Оттуда начали выплывать куски отслоившейся сажи. В общем промыл стряхнул и пошел подрубать это чудо на столе к аккумулятору от упса, ну и само собой к ноуту. Так как кнопки калибровки у меня не выведено залез в LM Programmer и нажал кнопку сброса калибровок. Вырубил питание врубил и запустил LogWorks2 для визуализации происходящего процесса. Датчик вначале нагрелся потом пошел прожигаться. Таким макаром я испарил весь спирт. Потом продул датчик. Оттуда высыпалось ещё намеренно сажи. Просушил ещё несколько раз чтобы быть уверенным что всё высохло и отвалилось. Потом запустил его на обычное измерение. Полежал он в таком состоянии 30 минут нагретый. Потом кинул датчик в открытое окно и опять запустил сброс калибровок. После так же Запустил в режим измерения. Датчик на открытом воздухе стал адекватно реагировать а не просто висеть в 20.9%. То есть стали колебаться десятые доли. После всего проделанного поставил обратно на автомобиль. Запустил матрицу и наслаждался идеальными показаниями. :D

Edited by Phant0m
Link to comment
  • 2 weeks later...

Выручайте, други!

Один "хороший" человек посеял заглушку от аналогово входа LC, ту, которая в виде маленького штеккера. :11: Что у неё внутри? Я подозреваю что какой-то резистор, но какой и на каких контактах.... :13:

Link to comment

Спасибо! :PIVO

Я на инновейтовском форуме уже вычитал. Нужен обычный стрео-джек 2.5 мм, замкнуть правый и левый каналы. Единственная фигня - не нашел джека с тонким корпусом, пришлось обпилить начинку обычного. Попробую найти и отрезать от какого-нибудь шнура.

Link to comment
  • 7 months later...
  • 3 weeks later...

матрицей Marsа теперь я пользуюсь, так вот недавно повторилась такая же хрень с показаниями ШДК, после перепрограммирования все пришло в норму, так, что это скорее всего косяк конкретного адаптера LC-1, но он как бы не сильно напрягает.

Link to comment
  • 3 months later...

Во время прошивания на 76% выскочила "Cant access device" :11: .

Я чуть не обосрался :22: . Но выход оказался прост. Если возникла ошибка или сбой во время программирования то просто снимите питание с контроллера, немного подождите. Потом включите, и заново запустите LM-Programmer. После того как он выйдет на связь заново залейте прошивку. :D

Судя по содержанию прошивки она стала немного пожирнее.

Что именно поменялось трудно сказать, будем наедятся что в лучшую сторону.

Edited by Phant0m
Link to comment

Вчера пробовал откатывать машину уже с новой прошивкой в LC-1.

НЕ СПЕШИТЕ ОБНОВЛЯТЬ! Постоянно во время работы выскакивает Ошибка 8.

В основном это происходит на сбросе газа. Причём совсем не адекватно.

Link to comment

Есть такое старое доброе правило - если все работает хорошо лучше не трогать ;)

 

Это же софт - новое не всегда лучше старого. Я ниразу не обновлял ни лс1 ни лм1 - не вижу необходимости.

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...